Вопрос Невозможно установить matplotlib в cygwin (проблема freetype)


Было бы неплохо иметь matplotlib в моей среде cygwin. У меня 64-разрядная версия Windows 8 с 64-разрядным cygwin.

Когда я печатаю:

pip install matplotlib

После сообщения об ошибке я получаю сообщение:

 * The following required packages can not be built:
 * freetype

По apt-cyg у меня уже установлены следующие пакеты:

Searching for installed packages matching freetype: 
cygwin32-freetype2
freetype2-debuginfo
libfreetype-devel
libfreetype-doc
libfreetype6

Что еще нужно? Как правильно установить freetype и matplotlib?


4
2018-06-18 00:25


происхождения




ответы:


У меня была такая же проблема на 64-битной Windows 7; Я решил это, установив пакеты Cygwin pkg-config а также libX11-devel перед вводом текста easy_install matplotlib==1.1.1 (версия 1.3.1 имеет ошибки на моей машине, следовательно, 1.1.1).


9
2017-07-23 12:24



Спасибо за предложение, я попробую. Что касается меня, я просто использую matplotlib вне cygwin (обычная установка Windows). - Alexey Petrenko


У меня также была та же проблема на 64-разрядной версии cygwin Windows 8. Я последовал совету в другом ответе (установите pkg-config а также libX11-devel), но пакет, который, наконец, позволил мне установить matplotlib, был libfreetype-devel, Тогда просто easy_install matplotlib==1.4.2,


3
2017-12-24 16:54